Segueix

matriu.cat funciona amb GNU Social 2.0.0-dev.
He aconseguit instal·lar aquesta versió sense errors gràcies a actualitzar el servidor de base de dades MariaDB a la versió 10.4.
Abans de fer-ho l'instal·lació de GNU Social donava molts errors al crear les taules:

nativecode=1067 ** Invalid default value for 'modified'

Fins que he trobat el motiu a mariadb.com/kb/en/library/date

"Since MariaDB 10.0.1, DATETIME columns also accept CURRENT_TIMESTAMP as the default value."

Tenia una versió de MariaDB anterior a la 10.1 per tant no li agradava gens 'default' => 'CURRENT_TIMESTAMP' en, per exemple, files com aquesta de :

'modified' => array('type' => 'datetime', 'not null' => true, 'default' => 'CURRENT_TIMESTAMP', 'description' => 'date the tag was modified'),

En la captura es veuen tots els fitxers que provocaven error al crear les taules. Una bogeria !

@xaloc si t'ensenyo els logs la majoría de línies son vermelles 😂

Inicia la sessió per participar a la conversa
mastodont.cat, xarxa social pels catalans d'arreu.

Servidor en català per a la comunitat de llengua i cultura catalana d'arreu d'internet.